Yumbi Reportio Unavailable - Maintenance

Incident Report for YUMBI Platform

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 22:14 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 22:02 SAST

Identified

YUMBI Reportio is currently undergoing maintenance. We apologise for the inconvenience caused
Posted Jun 03, 2026 - 21:39 SAST
This incident affected: YUMBI Reports.